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1 Welcome to TaskAngel

  

Worried about all those things that you haven't had time to do? Let
TaskAngel take the stress away. TaskAngel helps you keep track of
everything you need to do, and choose the best thing to do right now.

This help file will introduce you to TaskAngel and show you its features. You
can also use it as your initial reference when you need help.

You can get more help online at www.taskangel.com

Getting started

Read the Introduction to get to know about TaskAngel and how to use it. 

Set aside a quiet hour and dump all of your to-do items out of your head and into TaskAngel.

If any task is less than two minutes work, do it now! For the rest, set dates and priorities, and
highlight key tasks with stars.

Use the power of projects, folders and contexts to organize your tasks into manageable
playlists. It's like iTunes for your tasks!

Use the sync function to upload your new tasks into Toodledo.com. TaskAngel can set up a
new account for you, free of charge. Or if you already have a Toodledo account, download
your existing tasks into TaskAngel. See Using TaskAngel with Toodledo.

Take your tasks with you on your iPhone, or other mobile phone or PDA. And keep in sync
between your computers at work and at home.

To see how to use TaskAngel as part of a fundamental change in how you organize your life,
see Using TaskAngel with Getting Things Done®.

http://www.taskangel.com
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2 Introduction

TaskAngel can help you get back in control, reduce the amount of stress in your life, and
make you more effective - and give you time to have more fun!

Getting started

Read this introduction chapter, and have a look at the guided tour, to
familiarize yourself with the basics of TaskAngel

Jump right in, and start capturing your task list

TaskAngel has lots of features to help you organize your tasks. But don't try to
use them all at once. Keep things simple - just a handful of projects and
contexts is all you need to get started.

Going further

Thousands of people have been helped by David Allen's teachings on how to
organize your workload. Read Using TaskAngel with Getting Things Done® to
see how this can work for you.

If you want to view your tasks from different computers and keep them all in
step, you can use Toodledo as your central hub and keep everything in step
with it. Read Using TaskAngel with Toodledo to see how.



Introduction 7

Copyright © 2011 by MyPocketSoft, all rights reserved

2.1 About TaskAngel

TaskAngel is an easy to use tool for organizing your personal workload.

By using TaskAngel you can:

 Ensure everything you have to do is gathered into one place
 Make sure nothing is forgotten
 Organize your tasks to make it easier to work through them
 Filter your tasks into many different views
 Sort your tasks in many different ways
 Quickly choose which task you are going to work on next
 Keep notes to refer to as you carry out your tasks
Keep everything in the Cloud
Access your tasks and notes from anywhere

If you are using David Allen's 'Getting Things Done ®' principles for managing your work,
TaskAngel has some great features to help you:

 Use Contexts to flag where you need to be when doing a task
 Use Projects to group tasks with a common purpose into action plans
 Use Goals to help you pay attention to your longer term ambitions
 Use Next Actions to flag the tasks that are ready for you to do as soon as you can
 Filter all tasks in a single project, or a single context, or list all your next actions, with
one click
 Quickly add or delete projects and contexts
 Change the 'next action' status of any task with one click

Do you need access to your tasks list at home and at school or work? And when you are
traveling? And when you are our shopping, or at the gym? TaskAngel works with Toodledo.
com to keep your task list online and available everywhere.Then you can:

 Use TaskAngel on multiple computers, all synchronized to the Toodledo hub
 Use Pocket Informant on your iPhone, other cell phones and PDA's
 Use TaskAngel to view your tasks offline, if you don't have an internet connection
 Automatically synchronize to Toodledo every hour, if you want to
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2.2 Why TaskAngel?

We all have too much to do and too little time to do it. The more we chase around, the less
we seem to get done. Work-life balance sounds great, but where did all the time go?

Get back in control

TaskAngel is a simple way of gathering together all of your tasks - big and small, work and
home, painful and fun - and getting ready for you to decide right now what you are going to do
next.

Remove the stress

Stop worrying about all the things you haven't done. They are all on your list. You just picked
the right thing to do next. So just do it, and come back for more when you're ready.

Be more effective

Quickly cut through the blizzard of actions on your list, and pick out the ones that really
matter.

Have more fun

Spend more time having fun with family and friends. Create fun projects, with fun actions.
They'll all come up on your list along with all the more painful chores.

Concentrate

Devote an hour to one of your projects. Filter just the tasks for that project, and forget about
everything else. Choose the next action. Then just do it.

Everything in one place

TaskAngel keeps all your tasks together in one big list. The filters and flags make sure that
you only see the right tasks for what you are doing right now.

Fast filtering

TaskAngel provides rapid filtering, using automatic filters for every project and every context.
Or tasks that are overdue, or due by the end of this week. Or tasks you have highlighted with
a star. Completed actions are filtered out, unless you choose to show them.

Easy editing

You can change tasks directly on your tasks list, without having to switch to another window.
Or you can go to a different window if that's what you want. You can add or delete tasks with
one click.

Rapid sorting

Each row in the task list is a different task, and each column holds a different property - for
example, due date, next action, or project. You can sort on any of the properties by clicking on
the column header. You can hide any of the columns you don't use. Only use what you want -
keep it simple!
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Automatic sync

TaskAngel works as an offline companion to Toodledo, keeping your task list safe online, and
letting you keep in sync other computers, phones and personal digital assistants.

Free trial

Try TaskAngel for 30 days free of charge. Give it a chance to make you more effective. If it
does, buy it.

Help when you need it

This user guide is provided as part of your TaskAngel installation. You can get further
information and updates from TaskAngel.com
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2.3 How to buy TaskAngel

After downloading TaskAngel you may continue to use all of its features for a trial period of 30
days. After this time, if you wish to continue using it, you must buy it.

To buy TaskAngel, please visit the "Buy" page at www.taskangel.com. After you have made
your payment, you will be sent an email containing a unique license key. To register
TaskAngel, go to Help->Register TaskAngel, and type in your serial number. This removes
the 30-day limit.

The licence allows you to run TaskAngel on two computers.

http://www.taskangel.com
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2.4 Getting help

To read the user guide from within TaskAngel, hit the F1 key. 

To get help online, go to Help->Online Help.

For general information about TaskAngel, go to Help->TaskAngel Online, or visit  www.
taskangel.com. The site also contains a web version of this User Guide, and a printable
version in Adobe PDF format.

http://www.taskangel.com
http://www.taskangel.com
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3 Guided Tour

Main Window

The main window of TaskAngel has a Menu and Toolbar at the top, and a Status Bar at the
bottom. The large panel to the right is your Task List, with the  Note Panel below it. The
smaller panel to the left is the Filter Panel. Hidden behind the Task List is the Note List. You
can switch between the Note List and the Task List by clicking the tab or pressing F5.

The next few pages of this guide describe these visual elements in more detail.
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3.1 Task List

The Task List shows all or some of your tasks, depending on the choices you make on the 
Filter Panel. 

The columns show the various properties of your tasks, as indicated by the words or icons at
the top of each column. To see the meaning of an icon, hover your mouse over it. The
meanings of all these properties are described in the Task Properties page.

The icon on the left  shows if the task is a member of a group or on its own. See Groups
and Subtasks. You also use the icon for Drag and Drop.

You may find you don't need all of the columns. For example, some people don't bother with
Start Dates. To hide a column, right-click the column header, or choose View->Show / Hide
Columns. This brings up a list of columns. Uncheck any columns you wish to hide. 

You can change the order of the columns. Just drag a column header to where you want it to
be.

You can change the width of the columns. Just drag the left or right border in the column
header.

You can change the order of the tasks in the list. Click on a column header to sort by the
contents of that column. Click again to reverse the order.

You can change any of the properties of a task. Just click on the entry and change it.
Alternatively, double-click on a task to bring up the Task Properties window.

You can switch between the Note List and the Task List by clicking the tab or pressing F5.
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3.2 Note Panel

Below the Task List is the Note Panel. 

If the currently selected task has a note, it is displayed in the Note Panel. You can make
changes to the note, or you can write a note for a task that doesn't already have one.

The toolbar at the top of the Note Panel lets you cut or copy text to the clipboard, or paste
from the clipboard. You can also use it to make your text bold or italic, or to make numbered
or bulleted lists.

If you type in the address of a web page, this is recognized automatically. If you click on it, the
web page is opened in your browser.

You can also link to an email address, if you preface it with mailto: - for example, mailto:
support@mypocketsoft.com. 

You can put the Note Panel on the right hand side of the task list, instead of below it. Select
View / Show Notes to Right.

mailto:mailto:support@mypocketsoft.com
mailto:mailto:support@mypocketsoft.com
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3.3 Note List

Every task can have a note. But you can also keep notes that are independent of any tasks.
These are shown in the Note List. This shows all or some of your notes, depending on the
choices you make on the Filter Panel. 

The columns show what project or folder each note is assigned to, and the dates each note
was added and modified. To hide a column, right-click the column header, or choose View-
>Show / Hide Columns. This brings up a list of columns. Uncheck any columns you wish to
hide. 

You can change the order of the columns. Just drag a column header to where you want it to
be.

You can change the width of the columns. Just drag the left or right border in the column
header.

You can change the order of the notes in the list. Click on a column header to sort by the
contents of that column. Click again to reverse the order.

You can change any of the properties of a note. Just click on the entry and change it.
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Alternatively, double-click on a note to bring up the Note Properties window.

You can switch between the Note List and the Task List by clicking the tab or pressing F5.
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3.4 Filter Panel

The Filter Panel allows you to make choices about which of your tasks will be shown in the 
Task List.

Near the top of the Filter Panel is the "Show Completed" checkbox.
Unless this box is checked, the completed tasks will be hidden in
your task list.

Below it is the Search box. If you type in your search text and then
hit enter or click on the blue search icon, your task list will show all
the tasks that contain that text. So you can see all tasks concerning
Tom, for example, ready for an upcoming call or meeting.

If you use the red search icon, each task's notes will also be
searched for the text you want.

Below the search box there is the Filter Tree, which contains many
different ways in which you can filter your tasks. This is explained in
the chapter entitled Searching & Filtering.

You can expand or hide the items in any of the filter categories, by
clicking on the icon to the left of the filter category title.

You can also use the Filter Panel to filter which notes will be shown
in the Note List.
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3.5 Menu and Toolbar

TaskAngel's commands can be accessed using a menu at the top of the window, as normal.
The most frequently used commands are represented in the Toolbar. If you hover your
mouse over a toolbar button or a menu item, it will tell you what it does.
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3.6 Status Bar

In the Status Bar, on the right you can see a summary of how many tasks and projects you
have.

If you have synced with Toodledo, the sync status is shown on the left side of the status bar. 

See the chapter Using TaskAngel with Toodledo. 
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4 The Basics

This chapter covers the basic information you need to get started, in the following sections:

Task Properties
Note Properties
Adding, changing and completing tasks
Start dates, due dates and repeats
Reminders
Using stars
Setting priorities
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4.1 Task Properties

The columns in the Task List show the properties of each task, are shown in the table below.
To change the properties of a task, enter the new value directly in the Task List, or press F4
and change the value in the Task Properties dialog. You can change the properties of several
tasks at once, if you select them all before you press F4.

Task Properties

Icon Use this to drag and drop a task. It is also used to indicate task grouping.

Completed Checked when the task has been done

Starred Use this to highlight tasks for special attention

Next Action Use this to indicate tasks that are ready to be done as soon as possible

 Note Indicates if a note is attached to this task. If it is, you can view or edit the note in
the Note Panel. You can add a note to a task by typing into the Note Panel.

Task A few words stating what is to be done

Project A topic for grouping tasks - for example, something you have promised to deliver,
the outcome of several tasks. (You can call projects 'Folders' if you prefer. Choose
View->Use Folders)

Context The best location for this task - for example, Office, or Home, or Computer

Goal Short-term, long-term or lifetime goal addressed by this task

Tag You can give one or more tags to any of your tasks, to help organize your
workload

Start Date The date you will start this task, or the date it did start

Start Time If you have set a start date, you can set what time of day it started, or is due to
start

Due Date The date you have promised to complete this task. Leave it blank if the due date is
flexible

Due Time If you have set a due date, you can set what time of day it is due

Reminder If you have set a due date and time, you can ask for a reminder before it is due

 
Repeat or
Regenerate

If a recurring task is to be done regularly, set this to Repeat Regularly. If the task
is to be repeated a given time 
after its last completion, set it to Regenerate on Completion.

Frequency For a recurring task, gives the frequency of recurrence.

Priority The priority you give to this task - negative, low, medium, high or top. Negative
priority tasks are hidden.

Status Shows if the task is active, or being planned, or postponed, for example. Also
shows if it is the Next Action

Added Date Shows when the task was added. You can sort on this field to see your most
recently added tasks.

Modified Date Shows when the task was last modified.You can sort on this field to see your
most recently modified tasks.

Completed
Date

If the task has been completed, this shows when.You can sort on this field, and
change the completed date by clicking on it.
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4.2 Note Properties

The columns in the Note List show the properties of each note, are shown in the table below.

To change the properties of a note, enter the new value directly in the Note List, or press F4
and change the value in the Note Properties dialog. You can change the project or folder of
several notes at once, if you select them all before you press F4.

Note Properties

Note The title of the note

Project or
Folder

The project associated with the note. (You can call projects 'Folders' if you prefer.
Choose View->Use Folders)

Added Date Shows when the task was added. You can sort on this field to see your most
recently added tasks.

Modified Date Shows when the task was last modified.You can sort on this field to see your most
recently modified tasks.
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4.3 Adding, changing & completing tasks

To add a new task to the Task List, click on New Task in the toolbar. 

This throws up a window in which you can enter all the details of the new task. Press OK to
complete it.

The default values for the properties of a new task are based on the current task you have
selected.

To complete a task, click on the "completed" box for the task, on the Task List.

To remove a task without completing it, click on 'Delete Task' in the toolbar, or use Ctrl+Del
as a keyboard shortcut. You can select a number of tasks and delete them all in one go.

To delete all completed tasks, choose Edit->'Delete all completed tasks' in the main menu.

To change any property of a task, click it in the Task List and change it there. Or double-click
the task, or press F4, and the Task Properties window pops up, for you to make your
changes.

To change the same property in several tasks at once, select the tasks then press F4. You
can't give all the the tasks the same title, or the same note.

To hide a task, set its priority to Negative. Then the task will be hidden unless you have opted
to view negative priority tasks. To do this, choose View->Show Negative Priority.



TaskAngel - User Guide24

Copyright © 2011 by MyPocketSoft, all rights reserved

4.4 Start dates, due dates and repeats

To make your tasks easy to manage, only enter dates if you have to. Don't set a due date just
to bring a task to your attention. You can use Priority, Star or Next Action for that.

Generally speaking you should set a due date on a task if you have promised someone else
you will do it by then, or if you have promised yourself.

To set a date, click on it. A date-picker window pops up. You can browse through the
calendar, or use one of the handy shortcuts.

You can also set start times or due times for your tasks. To set a time, click on it and select
the time you want.

If you want to do a task regularly, for example "Clean the car every Sunday", set the task to

Repeat Regularly  , with a due date of next Sunday, and set the frequency to Weekly. You
can do this in the Task List, or in the Task Properties window.

Some tasks you might plan to do every Sunday, but maybe you don't actually do it until
Wednesday. When do you want to do it next time? If you want to stick to your schedule, then
leave it at Repeat Regularly. But if you want to wait a whole week before doing it again,
change your repeat setting to Regenerate on Completion. How dirty can a car get in four
days?

The icon for Regenerate on Completion has a red check-mark running through it   .
Clicking on the icon changes the repeat setting.
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4.5 Reminders

You can ask to be reminded in advance of a task becoming due.

First, set a due date and a due time for the task. Then choose how long in advance you want
to be reminded. The alarm bell icon lights up if the reminder has been set correctly. It won't
light up if the reminder time is in the past.

When a task reminder is due, a notification window pops up and a notification sound can be
heard.

TaskAngel can only monitor reminders if it is running, or parked in the System Tray. Click the
Close icon in the top right corner of TaskAngel, to park it in the System Tray. See Parking in
the System Tray.

You can set TaskAngel to start automatically when Windows starts. Just check the item in
the File menu.
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4.6 Using stars

Stars  give you a way of highlighting tasks in any way you want.

You might want to use a star to indicate high priority tasks. Then you could hide the Priority
column. (To see how to hide a column, read the Guided Tour.)

Or you can use stars to help pick specific tasks you are interested in. For example, before
you go shopping, you could star each task which needs to be done during your shopping trip.

To give a star to a task, just click its star icon in the tasks list. To take the star away, click it
again.

To list only your starred tasks, click on the Starred filter in the Filter Panel. See Searching &
Filtering.

To print your starred tasks, filter them and then print your filtered list. See Printing Tasks.
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4.7 Setting priorities

You can give priorities to your tasks, as follows:

Top Highest priority. Top priority tasks are all included in the hotlist.

High Normal high priority. Aim to have around 20% of your tasks in this category

Medium Normal medium priority. Aim to have around 60% of your tasks in this
category

Low Normal low priority. Aim to have around 20% of your tasks in this category

Negative Tasks given a negative priority are hidden from your Task List, except when
you are using the Negative Priority filter or the Completed Tasks filter. You
can override this behaviour by checking the menu item View->Show Negative
Priority. Then negative priority tasks are not hidden.

You can sort your tasks into priority order (see Sorting your tasks) and you can filter your
tasks by priority (See Searching & filtering).
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5 Organising your workload

This chapter covers the different ways TaskAngel helps you organize your tasks:

Using projects and folders
Using contexts
Using goals
Using tags
Groups and Subtasks
Drag and Drop
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5.1 Using projects and folders

Projects and Folders provide you with a  powerful way to manage your tasks. They tell you
about why each task is to be done. They help you decide which of your tasks is to be done
right now.

Projects

You can group your tasks into projects. A project is a significant outcome made up of a
number of tasks. For example "Decorate the Master Bedroom" could be a project. This would
contain a several tasks, including things like "Buy paint". Projects remind you why each task
is being done.

To add, rename or delete a project, go to the appropriate item in the Edit menu.

To assign a task to a project, set its Project property. See Task Properties.

To assign several tasks to a project all at once, select them, press F4, and choose the
project. Or hold down the Ctrl key and drag them onto the project in the Filter panel.

If you rename a project, all of the tasks in that project are adjusted automatically.

If you delete a project, you are asked if you also want to delete any tasks assigned to that
project. If not, they are reset to "No Project". 

To see all the tasks assigned to a project, select the project in the Filter Panel.

Decide which of the tasks in your project is to be done next, and set it as the Next Action.
See Selecting the next action.

You can also use projects to organize your notes. See Note Properties.

Folders

Some people prefer to organize their tasks and notes into Folders rather than Projects. If you
want to do this, go to the main menu and choose View->Use Folders. Folders and Projects
work in exactly the same way, and the two terms are used interchangeably.

Archiving

You can archive Folders and Projects when you have finished with them. Click on Archive in
the main menu. When a project is archived, it disappears from the filter panel and the drop-
down lists of projects. All tasks and notes assigned to archived projects are hidden from the
Task List, although they are included in search results.
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5.2 Using contexts

Contexts tell you about where each task is to be done. They help you decide which of your
tasks can be done right now.

Contexts

You can assign your tasks to contexts. A context is where a task is to be done. Here's a
suggested list of contexts to get you started:

Agendas In a meeting

Anywhere Anywhere

Calls In a phone call

Computer At your computer

Errands Out and about, e.g. shopping

Home At home

Office At the office

Read/Review Where your reading pile is

Someday/Maybe Not anywhere right now

Waiting for This is for tasks other people are doing

To add, rename or delete a context, go to the appropriate item in the Edit menu.

To assign a task to a context, set its Context property. See Task Properties.

To assign several tasks to a context all at once,select them, press F4, and choose the
context. Or hold down the Ctrl key and drag them onto the context in the Filter panel.

If you rename a context, all of the tasks in that context are adjusted automatically.

If you delete a context, any tasks assigned to that context are reset to "No Context". They are
not deleted.

To see all the tasks assigned to a context, select the context in the Filter Panel.



Organising your workload 31

Copyright © 2011 by MyPocketSoft, all rights reserved

5.3 Using goals

Goals

Goals are things you are striving to achieve, with a longer term perspective than you have
when you are thinking about projects and tasks. There are three types of goal, each with a
different perspective:

Lifetime goals

Long-term goals

Short-term goals

Long-term goals can contribute to lifetime goals. And short-term goals can contribute to long-
term or lifetime goals.

For example, you might set "Be healthy" as a lifetime goal. And you could set "Keep fit" as a
long-term goal that contributes to it. If you decide to take up jogging, you could have "Start
jogging" as a short-term goal. To get you started, you could have "Couch to 5K" as a project,
containing tasks like "Download Couch to 5K Podcast" and "Buy some running shoes".

To add, rename or delete a goal, or to view or edit its properties, go to the appropriate item in
the Edit menu.

To assign a task to a goal, set its Goal property. See Task Properties.

To assign several tasks to a goal all at once, select them, press F4, and choose the goal. Or
hold down the Ctrl key and drag them onto the goal in the Filter panel.

If you rename a goal, all of the tasks with that goal are adjusted automatically.

To see all the tasks assigned to a goal, select the goal in the Filter Panel.

Goal Tree

You can choose how you want goals to be shown in the Filter Panel. If you choose View-
>Use Goal List, the goals are listed by type (lifetime, long-term or short-term). If you choose
View->Use Goal Tree, the goals are listed in a tree structure, so you can see which goals
contribute to which longer-term goals.

When you are using Goal Tree view, the task filter takes account of contributing tasks. So
using the above example, filtering on Be Healthy would show you all tasks assigned to Be
healthy, Keep fit and Start jogging.

You can drag and drop goals within the tree structure. The goal type of the goal being
dragged is adjusted accordingly. You can't make a goal contribute to a short-term goal.

Goal Progress

You can see what progress you are making towards any of your goals. Select Edit->Goal-
>Goal Properties, and choose the Progress tab.
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The progress report tells you
how many tasks are completed
and uncompleted for this goal
on its own, and for this goal
including any contributing
goals.

The 30-day chain of completed
tasks looks at the last 30 days
and shows you on which of
those days tasks were
completed towards the goal, or
any of its contributing goals.  To
make sure you are doing things
every day towards a goal, try to
keep an unbroken chain for the
whole 30 days.

Archiving

You can archive goals when you have finished with them. Click on Archive in the main menu.
When a goal is archived, it disappears from the filter panel and the drop-down lists of goals.
All tasks assigned to archived goals are hidden from the Task List, although they are included
in search results.

When you are using Goal Tree view, archiving a goal also archives any lower level goals that
contribute to it.
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5.4 Using tags

Tags are labels you can give to tasks, to help you organize your workload in any way you
want. Each task can have as many tags as you like.

To add, rename or delete a tag, go to the appropriate item in the Edit menu. 

To assign a tag to a task, set its Tag property. See Task Properties.

To give the same tag to a number of tasks all at once, select them, then press F4 and select
the tag. Or hold down the Ctrl key and drag them onto the tag in the Filter panel.

If you rename a tag, all of the tasks that have that tag are adjusted automatically.

If you delete a tag, it is removed from all the tasks that are using it.. 

To see all the tasks with a given tag, select the tag in the Filter Panel.
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5.5 Groups and Subtasks

If you have a complex task, you can break it down into a number of subtasks. The original
task and its subtasks form a task group. The original task becomes the parent of the group.

To group several tasks together, select them and choose Right-click -> Group. The blue task

icon changes to show when a task is a subtask  or the parent   of a task group.
Subtasks have their Task descriptions indented.

To hide the subtasks of a group, close the group by clicking on on the Icon of the group's

parent task. The icon changes  to show when a group is closed.

To create a new task as a subtask of an existing task, click on New Subtask in the toolbar.
You cannot give a subtask to a subtask.

To make an existing task become a subtask of another task, drag it onto its new parent. To
make a task join an existing group, drag it into the group.

To remove a task from a group, right-click on it and choose Ungroup. To turn a whole group
back into normal tasks, ungroup the parent task.

The parent of a task group cannot be made a subtask in another group.

Sorting

When you sort your task list, all of the member of a group are kept together, if the parent of
the group is visible. If you want the subtasks to be sorted in the same order as the overall
task list, choose Menu->View->Sort Subtasks. Otherwise you can drag the subtasks into
whichever order you want.

Repeating groups and subtasks.

If the parent of a task group is set to repeat, what happens to its subtasks when you complete
it? That depends on the repeat settings of the subtasks.

Subtasks with no repeat are not carried forward to the next version of the parent task.
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Subtasks set to Repeat With Parent are carried forward, and their dates are adjusted by
the same amount as the parent task.
Subtasks with other repeat settings are carried forward but their dates are not changed.

What if you complete a subtask?

Subtasks set to Repeat With Parent are set to Completed. But they don't repeat until the
parent task is completed.
Subtasks with other repeat settings are repeated according to those settings. They stay in
the same group.
Subtasks with no repeat settings are completed, with no repeat and no carry forward. 

Subtasks and Toodledo

If you are syncing TaskAngel with Toodledo, to use Groups Subtasks you need a Toodledo
Pro account. If you don't have one, TaskAngel's Groups and Subtasks will still work, and you
can still sync with Toodledo. But if you use Toodledo to change a subtask, it will be taken out
of whatever group it was in.



TaskAngel - User Guide36

Copyright © 2011 by MyPocketSoft, all rights reserved

5.6 Drag and Drop

You can drag tasks into a task group, to make them part of that group. See Groups and
Subtasks.

To drag and drop a task, drag the Task Icon  with your mouse.To drag and drop several
tasks at once, select them first, then press Ctrl and drag and drop one of the selected tasks.

You can drag tasks onto the Filter Panel to assign properties to them. You can use this
feature to assign the same property to several tasks at once.

You can drag and drop goals within the Goal Tree. See Using goals.
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6 Deciding what to do next

Having organized your tasks, you now have have to pick something to do, and do it! This
chapter tells you how.

Selecting the next action
Sorting
Searching & filtering
The hotlist
Custom Filters
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6.1 Selecting the next action

It's no good just listing your tasks. You have to do them. You can only do one at a time. So
which one is it going to be? Scanning your entire task list can be very overwhelming, so you
can divide and conquer by organizing tasks into Projects and assigning them to Contexts.
The next step is to identify which of them are 'Next Actions'.

The Next Action is the next physical task that needs to be done, to move forward. Each of
your projects should have a next action. So on your entire Task List, you will usually have
several next actions.

To identify a task as a next action, click the Next Action icon   on the Task List, or set its
Status to Next Action. See Task Properties. If you click on the icon again, Next Action is
turned off, and the Status is set to None.

To list only your next actions, click on the Next Action filter. See Searching & Filtering. This is
an excellent way to narrow down your choice of what you are going to actually do next.
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6.2 Sorting

At the top of the Task List there is a header, with the titles of each column. To sort your tasks,
click the title of the column you want to sort by.

For example, click the word Task to sort your tasks alphabetically. Click again to reverse the
order.

You can sort on any of the columns apart from the blue Icon (normally the first column),
which is used for dragging and dropping tasks and for showing task grouping.

You can sort by up to three different properties at the same time. To do this, go to Menu-
>View->Sort Tasks, then choose which properties you want to sort by.

If you want subtasks to be sorted, ensure Menu->View->Sort Subtasks is checked.
Otherwise, you can order them manually. See Groups and Subtasks.

See also Task Properties.

The Note List can be sorted in the same way.
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6.3 Searching & filtering

Most of us have lots of things to do. We live stressful lives. TaskAngel starts to relieve that
stress when we capture every single task in one list - when there is nothing that we've
forgotten, only to be worried about in the middle of the night.

But no matter how many things there are on the list, you can only do one of them at a time.
So you have to decide what to do, then concentrate on doing it. Forget about everything else
for a while. To the left of the Task List is your Filter Panel. This is where you make the
choices. There is one Search box, and a whole list of filters of different types.

Searching and Filtering works for your Notes as well as for your Tasks.

Searching

To search for tasks containing a given word or phrase, type your search text into the Search

box and press the Enter key or click on the search icon . Then your Task List will contain
only tasks that have that word or phrase in their subject. If you want to include completed
tasks, check the Show Completed box. If you want to include the notes attached to each task,

use the red search icon , or press Shift+Enter.

This is ideal for pulling together all the tasks relevant to a person you are going to call, or a
meeting you are about to attend.

Filtering

To cancel a search and go back to viewing all your tasks, click on the All Tasks filter.

To filter your tasks based on their properties, click on one of the filters in the Filter List. 

The Filter List can get quite long if you have lots of projects and contexts, but you can
collapse or expand each filter type by clicking on the icon to the left of the filter type. If you
choose Auto Collapse Filters in the View menu, then when you expand a filter type, all other
types are collapsed.

Filtering Subtasks

If you want to view all tasks in a task group whenever the parent of the group is visible,
choose Filter Subtasks with Parents in the View menu.
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Filter types

The filter types are as follows:

 All Tasks Show all tasks

 Hotlist Show your hotlist. See The hotlist.

 Starred Show tasks you have highlighted with a star. See Using stars.

 Next action Show tasks you have identified as next actions. See Selecting the next
action.

 Completed Show tasks you have completed.

 My Filter Use a custom filter you create yourself. See Custom Filters

 Projects /
Folders

Show all the tasks in a project or folder. See Using projects and folders. 

 Contexts Show all the tasks for a context. See Using contexts

 Goals Show all tasks that address this goal. If you are using Goal Trees,
include tasks addressing contributing goals. See Using goals

Tags Show all tasks that have this tag. See Using tags

 Start by Show tasks starting by a given date. These are cumulative, so for
example the list of tasks starting by tomorrow includes tasks starting
today.

 Due by Show tasks due by a particular date. These are cumulative, so for
example the list of tasks due by tomorrow includes tasks due today.

 Priority Show tasks with given priorities. The Negative priority filter is the only
way of seeing tasks with negative priority, as they are normally excluded
from the Task List. See Setting priorities.

 Status Show tasks with given status.
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6.4 The hotlist

Some times a task comes in that is so important that everything else takes a step back. The
hotlist helps you keep focus on those immediate tasks.

The hotlist is automatic. A task gets onto the hotlist if you give it Top Priority, or if it is due
today or tomorrow. Remember you should only set a due date on a task if you have promised
to someone else it will be done by that date, or if you need to do it to keep a plan on track. If
you have a lot of bogus due dates in your task list, your hotlist will lose focus.

See also Start dates, due dates and repeats, and Setting priorities.
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6.5 Custom Filters

If the ready-made filters don't meet all of your needs, you can create your own. These appear
as My Filters in the Filter Panel.

To bring up the Custom Filter window, right-click on My Filters in the
Filter Panel, and select New Filter.

The Custom Filter window shows all the normal TaskAngel filters, with
check boxes against each one. If you click once on the check box, you
will see a green check mark. This means that tasks with this property
will be selected by your new filter. 

If you click again on the check box, you will see a red 'no entry' sign.
This means that tasks with this property will be blocked by your filter.

In the example to the left, the "Today only" filter will show tasks that are
due today, but not ones that are overdue.

You can bring as many properties into play as you like. So in this
example, if you put a green check against Starred, your filter would
show tasks that are starred and due by today but not overdue.

At the top of the window, give the name of your custom filter. This will
then be listed under My Filters.
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7 Cloud computing

TaskAngel lets you keep your information in the Cloud - on Toodledo's secure information
servers. This ensures your information is held in a secure environment, accessible from
wherever you are, using whatever device you want.

Using TaskAngel with Toodledo
Sync with your phone or PDA
Sync with other computers
Internet Connection Problems
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7.1 Using TaskAngel with Toodledo

 Toodledo is one of the first really popular cloud computing services, where your personal to-
do lists are held on a secure server on the other side of the world, and accessed over the
web. You can find out all about Toodledo from their web site at www.toodledo.com. If you are
already a Toodledo user, you can use TaskAngel with your existing account.

TaskAngel gives you all the richness and immediacy of a desktop application, with the
addition of Toodledo as a synchronization server. This gives you a number of benefits:

Backup: Toodledo acts as a secure backup server. If you lose your local copy of your task
list, you can get it back from the server.

On the go: Hand-held devices such as the iPhone and Blackberry have the ability to sync to
Toodledo, so you can easy feed changes back and forth between them and TaskAngel.

Work and play: You can keep one copy of your task list on your work PC, and another at
home. TaskAngel sync keeps them up to date with each other.

To sync with Toodledo, click on the Sync button   in the TaskAngel toolbar. The first time
you do this, a window pops up for you to enter the details of your Toodledo account. If you
don't have a Toodledo account, TaskAngel can set one up for you.

TaskAngel then automatically signs into Toodledo and syncs your  projects, contexts and
tasks. The progress of the sync is indicated in the status bar at the bottom of the TaskAngel
window.

If TaskAngel reports that it cannot connect to Toodledo, you might be being blocked by a
firewall. See Internet Connection Problems.

http://www.toodledo.com
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After sync is complete, you can go offline if necessary and work on your tasks as normal. 

TaskAngel will sync your tasks automatically every hour, as long as you remain connected to
the Internet. To disable this, uncheck Auto Sync on the Sync menu.

When you are using Auto Sync, you can use the Instant Sync option. This syncs with
Toodledo whenever you make a change, rather than waiting until the hourly sync becomes
due. TaskAngel waits for one minute to make sure you have finished making your changes,
then syncs with Toodledo.

The sync menu also provides a Renew Sync option. You can use this if you want to change
your Toodledo settings. You can also use it if you think Toodledo and TaskAngel have fallen
out of step.

Please note that TaskAngel does not currently support every feature of Toodledo. For
example, advanced repeats are not supported in the current version of TaskAngel.

If you want to use Groups and Subtasks, you will need a Toodledo Pro account.

The Sync menu contains a further menu item - Get Proxy Info. You won't normally need to
use this. It's provided to help troubleshoot Internet connection problems.
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7.2 Secure Connection

If you have a Pro account on Toodledo, you can use a secure connection between TaskAngel
and Toodledo, to reduce the risk of anyone intercepting your information.

To use a secure connection, choose Sync->Use Secure Connection, on the main menu.
This only works if you have a Toodledo Pro account.
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7.3 Sync with your phone or PDA

TaskAngel syncs with Toodledo, so any handheld device that can work with Toodledo can
work with TaskAngel. 

For example:

iPhone Download Toodledo from the App Store

Android Use Got To Do. See their blog at gottodoapp.wordpress.com

Blackberry Use TaskJot. See their site at www.taskjot.com

Windows Mobile Use the Toodledo web portal at www.toodledo.com/slim

Also many variants of Pocket Informant will soon have Toodledo sync capability. The iPhone
version can already sync with Toodledo. 

http://gottodoapp.wordpress.com
http://www.taskjot.com
http://www.toodledo.com/slim
http://www.pocketinformant.com
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7.4 Sync with other computers

If you have computers at home and at work, you can access your tasks on both, and keep
them in sync. TaskAngel uses Toodledo.com as a hub for synchronization with other
computers.

You can see Toodledo for yourself at www.toodledo.com. You can open an account there,
free of charge. Or TaskAngel can create an account for you. See Using TaskAngel with
Toodledo.

TaskAngel will pass changes back and forth with Toodledo, so that multiple versions of
TaskAngel on different computers are all kept up to date, so long as you keep them synced
regularly. TaskAngel syncs with Toodledo automatically every hour, while you are connected
to the Internet.

http://www.toodledo.com
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7.5 Internet Connection Problems

If you have trouble getting TaskAngel to connect to Toodledo, it might be because traffic
between them is being blocked by a firewall.

TaskAngel uses the same Internet connection settings as Internet Explorer. This is usually
sufficient. But if you are connecting to the Internet via your company's network, you may need
to tell TaskAngel about your company's proxy authentication settings.

Choose Menu->Sync->Proxy Settings. A window pops up.

Check the checkbox, and enter the username and password required by your proxy. These
are usually the same as the ones you use to log onto your company's network.

Then try syncing with Toodledo again. If the connection still doesn't work, ask your company's
IT support people for advice. 

You can also try unsetting Use Secure Connection, in case there is a problem with using
secure communications on your network.
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8 Using TaskAngel

This chapter covers the usability features of TaskAngel:

Printing
Saving your tasks
Changing the task file
Take your tasks with you

Parking in the System Tray
Keyboard Shortcuts and Hot Keys
Start When Windows Starts

Using TaskAngel with 'Getting Things Done®'
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8.1 Printing

You can print your entire Task List, or print a filtered view of it. Or you can print the details of
individual tasks. Or you can print notes from your Note List.

Step1 - Page Setup

In the top menu, go to File->Page Setup. A window pops up.

Choose if you want to print a list of tasks, or the details of just one or more selected tasks.

Choose the orientation of your printout, and the margins. You can specify the margins in
inches or millimeters.

Choose which font is to be used for your printout. For example, you can make the font
smaller to fit more on the page, or bigger to make it easier to read. 

Step 2 - Decide what is to be printed

When you print the Task List, what you see is what you get. So make sure the filters are set
to give you the tasks you want to print. See Searching & Filtering.

When you print Task Details, select one or more tasks from your Task List. To select more
than one task, click on the first one, then hold down the Ctrl key and click on the others.
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Step 3 - Print it

In the top menu, go to File->Print, or click the Print button in the toolbar.

You can preview your print before sending it to the printer. Go to File->Print Preview, and a
preview window pops up. Set it to the size you want.

TaskAngel tries to lay out your printing nicely. However, when you are printing the Task List, if
you have too many columns, or if your font size is too big, the layout will be poor. Be selective
about which columns you print, then set the orientation to landscape, and choose a font size
that will fit.
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8.2 Saving your tasks

Your task list is kept in a special file, in TaskAngel's application settings folder. Every time you
make a change to a task, TaskAngel waits for one minute of inactivity, then saves your task
list automatically. When you close TaskAngel, or shut down your computer, the task list will
be saved if necessary. Your notes are stored in the same file.

The File menu has an item called Auto Save. You should keep this checked. If Auto Save is
not set, the task list will not be saved automatically, and you might lose your most recent
changes.

You can save the task list manually, using File->Save or Ctrl+S. This is not necessary if you
have Auto Save on.

You can change where TaskAngel keeps your tasks. See Changing the task file.
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8.3 Changing the task file

Normally, TaskAngel keeps all of your tasks in a single file called Tasks.xml, in your Windows
AppData folder. However, you can change this. For example, you might want to keep your
task file on a USB memory stick so that you can move it easily to another computer.

The File menu has the commands you need for this. Before you change your task file, we
recommend you sync your current task file with Toodledo.

To save your current task list to a new file, choose Save As and navigate to the folder you
want, then type the file name. TaskAngel creates a file with that name and location, and
switches to using that file.

To go back to using the default task file, choose Use Default Task File.

To change to a different task file - one that you have saved before - choose Open.

TaskAngel shows you which task file you using, in its caption bar (at the top of the TaskAngel
main window), if you are using a file other than the default task file.
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8.4 Take your tasks with you

When you are away from your computer, you still need to see your task list.

The easiest way to take your tasks with you is to print them out. See Printing tasks.

If you have computers at home and at work, you can access your tasks on both, and keep
them in sync. See Sync with other computers.

If you have a handheld device such as an iPhone or PDA, you sync TaskAngel with Toodledo,
and then sync your device with Toodledo. See Sync with your phone or PDA.
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8.5 Parking in the System Tray

When you have finished working with TaskAngel, you can minimize it or close it, just like any
other Windows program. But you also have a third option - to park TaskAngel in the System
Tray. While it is parked, TaskAngel continues to monitor any tasks for which you have set
reminders. It also continues to automatically sync with Toodledo every hour, if you have
chosen that option.

If you check Use System Tray in the File menu, TaskAngel will park itself automatically in the
System Tray when you click on the Close button at the top right corner of the TaskAngel main
window. Otherwise, clicking on the Close button will completely close TaskAngel.

You can also use Park in System Tray, in the File Menu, to park TaskAngel. Clicking on Exit
will always completely close TaskAngel, even if Use System Tray is checked.

When TaskAngel is parked, you can open it again by double-clicking on it.

If you right-click on TaskAngel while it is parked, it pops up a menu that allows you to create a
new task, or to open or close TaskAngel.
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8.6 Keyboard Shortcuts and Hot Keys

Keyboard Shortcuts

TaskAngel provides shortcut keys to speed up the operation of frequent tasks, or to allow you
to use TaskAngel without a mouse. The keys are consistent with Windows standards.

Hold the Alt key down to reveal the shortcut keys for menus and items in TaskAngel
windows.
Some of the menu items have additional shortcut keys, which are shown to the right of the
menu item text.
Ctrl+Insert creates a new task.

Ctrl+Delete deletes the currently selected tasks.

In the Task List, the right and left arrow keys open and close a task group, if you move the
focus to its parent task. See Groups and Subtasks.

F6 cycles the keyboard focus between the Task List, the Note Panel and the Filter panel.
See Guided Tour.
F5 switches between the Task List and the Note List

Shift+F10 pops up a context menu, like right-clicking the mouse.

In the Filter Panel, the right and left arrow keys expand and collapse a filter category.

In the Filter Panel, pressing a letter key takes you to the next item that starts with that letter.

F4 brings up the Properties window for the current task, where you can edit its individual
properties.
In the Properties window, use Tab to move between the properties in order, and use F4 to
open and close the drop-down lists for properties that have them.
Alt+F4 closes the current window. If this is the main TaskAngel window, it is parked in the
system tray if you have selected that option. See Parking in the System Tray.
F1 shows this user guide.

Hot Keys

Hot keys can be used to interact with TaskAngel even if you are working in another program.

Ctrl+Alt+T brings the TaskAngel window to the top, even if it is minimized or parked.

Ctrl+Alt+N creates a new task.

You can change which hot keys are used, by choosing Hot Keys in the File menu.
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8.7 Start When Windows Starts

You can set TaskAngel to start automatically when Windows starts. Just check the item in
the File menu.
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8.8 Using TaskAngel with 'Getting Things Done®'

David Allen's book  "Getting Things Done" describes a very practical process for personal
workload management. It has been adopted by thousands of people all over the world. But it
doesn't work easily with desktop software such as Microsoft Outlook, which was designed
before GTD came along.

TaskAngel has a number of features that make it a natural tool for Getting Things Done®.

Everything is collected together in big list. So you can see it all. Then the filters let you
see what's relevant to you right now.
Tasks are organized into Projects. A project is a set of individual tasks that combine to a
single outcome. 
Tasks can be given Contexts. A context is a location where tasks get done, like Home or
Work or Computer.
Tasks can be identified as Next Actions. A Next Action is the next physical task that
must be done to move things forward.
Filters help you make the best choices. One click gets you all your Next Actions, or all
tasks to be done at your Computer, or all overdue tasks. You can filter by words or phrases
too, so you can see all tasks concerning Sarah, for example, ready for an upcoming call or
meeting.
Use the same list everywhere. Print out your tasks and take them with you - all of them
or just the relevant filtered views. Sync your task list between computers at work and at
home, or with a handheld device, using Toodledo.

You can read all about GTD® on David Allen's website, or get "Getting Things Done" from
your library or favorite book store.

GTD® and Getting Things Done® are registered trademarks of the David Allen Company.
TaskAngel is not affiliated with or endorsed by the David Allen Company.

http://www.davidco.com
http://www.davidco.com/what_is_gtd.php
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9 Installing TaskAngel

To install TaskAngel, download the setup file from www.taskangel.com, and run it. A window
pops up.

When you click Next, you are shown the End-User License Agreement. If you agree with it,
click "I Agree".

On the next screen, you can choose the Install location.
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Change the location if you want to, then click Install. The installation process starts. This will
include installation of .NET Framework 2.0 if it isn't already installed.

Click on Finish, and the TaskAngel installer will present a final window. Click on Finish again,
and you're done. To start TaskAngel, click on its icon in the Windows Start Menu.
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9.1 About .NET Framework

.NET Framework is Microsoft's advanced software platform, which is used by TaskAngel. 

.NET Framework has been around for several years, and Microsoft are steadily enhancing its
quality and performance. Version 1.0 was built into Windows XP, version 2.0 was built into
Windows Vista, and version 3.5 was built into Windows 7.

The current version of TaskAngel uses .NET Framework Version 2.0. This is included in the
TaskAngel setup file. It is installed automatically if you don't already have version 2.0 installed.
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10 Frequently Asked Questions (FAQ)

This user guide aims to tell you everything you need to know about TaskAngel. For additional
information and clarifications, please visit our FAQ page at www.taskangel.com

http://www.taskangel.com
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